Составьте программу, которая позволяет проверить правописание "жи" и "ши" в тексте и выводит на экран количество допущенных ошибок и исправленную строку
Составьте программу, которая позволяет проверить правописание "жи" и "ши" в тексте и выводит на экран количество допущенных ошибок и исправленную строку
Ответ(ы) на вопрос:
Procedure GhiShi(Var S : String; Var N : Byte);
Var i : Byte;
Begin
N:=0;
For i:=1 to Length(S)-1 do
If (S[i] in ['ж','ш']) and (S[i+1]='ы') then
Begin
S[i+1]:='и';
Inc(N);
end;
end;
Var St : String;
k : Byte;
Begin
{ Readln(St); } St:='"жы" и "шы" пишы через "и"';
GhiShi(St,k);
Writeln(St);
Writeln('Количество ошибок: ',k);
end.
Не нашли ответ?
Похожие вопросы