Составьте программу которая в массиве A из 20 произвольных чисел находит произведение минимального элемента и среднего арифметического элементов данного массива
Составьте программу которая в массиве A из 20 произвольных чисел находит произведение минимального элемента и среднего арифметического элементов данного массива
Ответ(ы) на вопрос:
Лови)
const
k = 20;
var
A: array [1..k] of real;
i: integer;
min, average: real;
begin
writeln('Enter x:');
for i := 1 to k do
begin
A[i] := random(k);
writeln('A[', i, '] = ', A[i]);
end;
min := A[i];
average := 0;
for i := 1 to k do
begin
average := average + A[i] / k;
if min > A[i] then
min := A[i];
end;
writeln(min * average);
end.
Не нашли ответ?
Похожие вопросы