Составьте программу, которая выводит все делители натурального числа N (в паскале)

Составьте программу, которая выводит все делители натурального числа N (в паскале)
Гость
Ответ(ы) на вопрос:
Гость
var n,i:integer; begin write('n = '); readln(n); writeln('Делители:'); for i:=1 to n div 2 do  if n mod i = 0 then write(i,' '); writeln(n); end. Пример: n = 24 Делители: 1 2 3 4 6 8 12 24
Не нашли ответ?
Ответить на вопрос
Похожие вопросы