Составьте программу, которая заполняет массив а[1..10] случайными целыми числами от 0 до 2 и выводит на экран количество элементов, равных 1. Pascal Abc
Составьте программу, которая заполняет массив а[1..10] случайными целыми числами от 0 до 2 и выводит на экран количество элементов, равных 1.
Pascal Abc
Ответ(ы) на вопрос:
Гость
Program enot;
Var a: array [1..10] of integer;
i,k: integer;
begin
k:=0;
for i:= 1 to 10 do
a[i]:= random(2);
for i:= 1 to 10 do
if a[i]=1 then k:=k+1;
writeln(k);
end.
Гость
var a:array[1..10] of integer;
i,k:integer;
begin
randomize;
for i:=1 to 10 do begin
a[i]:= random(3);
write (a[i],' '); end;
writeln;
k:=0;
for i:=1 to 10 do
if a[i]=1 then k:=k+1;
writeln('Количество элементов равных 1 = ',k);
end.
Не нашли ответ?
Похожие вопросы