Составьте программу которая заполняет массив a[1..8] случайными целыми числами диапазоне от 1 до 10 и выводит на экран количество элементов с четными значениями и сумму элементов массива с нечетными значениями
Составьте программу которая заполняет массив a[1..8] случайными целыми числами диапазоне от 1 до 10 и выводит на экран количество элементов с четными значениями и сумму элементов массива с нечетными значениями
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(9,1,10); a.Println;
Writeln('Сумма четных ',a.Where(x->x.IsEven).Sum);
Writeln('Количество нечетных ',a.Where(x->x.IsOdd).Count)
end.
Пример
9 1 4 2 3 10 10 8 3
Сумма четных 34
Количество нечетных 4
Не нашли ответ?
Похожие вопросы