Составьте программу перевода двоичной записи натуральных чисел в десятичную.(В Pas
Составьте программу перевода двоичной записи натуральных чисел в десятичную.(В Pascal ABC)
Ответ(ы) на вопрос:
Var i: integer;
n,k: int64;
s: string;
begin
write('двоичное число: '); readln(s);
k:=1; n:=0;
for i:=length(s) downto 1 do
begin
n:=n+(ord(s[i])-48)*k;
k:=k*2;
end;
writeln('десятичное число: ',n);
end.
Не нашли ответ?
Похожие вопросы