Составьте программу решения следующей задачи: С клавиатуры вводится двузначное число a. Найти сумму его цифр.

Составьте программу решения следующей задачи: С клавиатуры вводится двузначное число a. Найти сумму его цифр.
Гость
Ответ(ы) на вопрос:
Гость
Program prog; Uses crt; var a: integer; begin clrscr; write('a = '); readln(a); if ((abs(a)>9) and (a<100)) then writeln('Sum = ', abs(a mod 10) + abs(a div 10)) else writeln('Error'); end.
Гость
var a,s:integer; begin write('a = '); readln(a); s:=(a div 10)+(a mod 10); writeln('s = ',s); end. Пример: a = 52 s = 7
Не нашли ответ?
Ответить на вопрос
Похожие вопросы