Составьте программу в Паскаль. В кафе продают лимонад по N руб. и мороженое по T руб. Составьте алгоритм, который сообщает "возьмите сдачу", "доплатите еще" или "спасибо за покупку" при оплате покупателем за M лимонадов и R мор...

Составьте программу в Паскаль. В кафе продают лимонад по N руб. и мороженое по T руб. Составьте алгоритм, который сообщает "возьмите сдачу", "доплатите еще" или "спасибо за покупку" при оплате покупателем за M лимонадов и R мороженых денег в размере S руб.
Гость
Ответ(ы) на вопрос:
Гость
var n,t,m,r,s,raznica:real; begin     writeln('Цена лимонада?');     readln(n);     writeln('Цена мороженого?');     readln(t);     writeln('Сколько покупаете лимонада?');     readln(m);     writeln('Сколько покупаете мороженого?');     readln(r);     writeln('Сколько даёте денег?');     readln(s);     raznica:=s-(n*m+t*r);     if raznica =0 then writeln('Спасибо за покупку!') else if raznica>0 then writeln('Возьмите сдачу: ', raznica, ' рублей') else writeln('Доплатите ещё ', abs(raznica), ' рублей'); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы