Составьте программу вычисления количества трёхзначных чисел у которых: цифры упорядочены строго по убыванию.

Составьте программу вычисления количества трёхзначных чисел у которых: цифры упорядочены строго по убыванию.
Гость
Ответ(ы) на вопрос:
Гость
Program Pr; var a:array[100..999] of integer; q,w,v,c,i,d:integer; Begin n:=-1; c:=1; For i:=1 to 899 do begin a[i]:=99+c; c:=c+1; q:=a[i] mod 10; a[i]:=a[i] div 10; w:=a[i] mod 10; a[i]:=a[i] div 10; if (q>w) and (q>a[i]) and (w>a[i]) then v:=v+1; end; writeln('Всего этих числел=',v); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы