Составьте программу вычисления суммы тех элементов одномерного массива А(N), что расположены перед последним нулевым элементом данного массива. Задача на языке Паскаль, помогите пожалуйста

Составьте программу вычисления суммы тех элементов одномерного массива А(N), что расположены перед последним нулевым элементом данного массива. Задача на языке Паскаль, помогите пожалуйста
Гость
Ответ(ы) на вопрос:
Гость
const   n=15; var   a:array[1..n] of integer;   i,k,s:integer; begin   Randomize;   Write('Массив: ');   k:=0;   for i:=1 to n do begin     a[i]:=Random(21)-10;     Write(a[i],' ');     if a[i]=0 then k:=i;     end;   Writeln;   s:=0;   for i:=1 to k-1 do s:=s+a[i];   Writeln('сумма элементов перед последним нулевым равна ',s) end. Пример Массив: -8 10 6 9 1 -3 2 -5 -6 0 -8 -2 -4 2 -4 сумма элементов перед последним нулевым равна 6
Не нашли ответ?
Ответить на вопрос
Похожие вопросы