Составьте программу вывода числа делителей натурального числа М В ПАСКАЛЕ ABC ПОЖАЛУЙСТА
Составьте программу вывода числа делителей натурального числа М
В ПАСКАЛЕ ABC ПОЖАЛУЙСТА
Ответ(ы) на вопрос:
Гость
var m,d,kol:uint64;
begin
read(m);
for d:=1 to m do begin
if (m mod d)=0 then inc(kol);
end;
write(kol);
end. Это программа для делителей от 1 до m.
var m,d,kol:uint64;beginread(m);for d:=2 to m-1 do begin if (m mod d)=0 then inc(kol); end;write(kol);end. Эта программа для делителей от 2 до m-1.
Не нашли ответ?
Похожие вопросы