Составьте программу, заменяющую меньшее из двух данных чисел на среднее арифметическое этих чисел,а большее из двух данных чисел-на произведение этих чисел.помогите пожалуйста,очень надо!
Составьте программу, заменяющую меньшее из двух данных чисел на среднее арифметическое этих чисел,а большее из двух данных чисел-на произведение этих чисел.помогите пожалуйста,очень надо!
Ответ(ы) на вопрос:
var x,y,k:real; begin readln(x,y); if x>y then begin k:=y; y:=(y+x)/2; x:=x*k end else begin k:=x; x:=(x+y)/2; y:=y*k; end; writeln(x,y,); end.
var a, b, c: real; {a и b - вводимые с клавиатуры числа, c - буферная переменная, которая будет содержать значение переменной a} begin writeln('Введите 2 числа'); readln(a, b); //Вводим числа c:= a; if a < b then {Если a < b, то заменяем а на среднее арифметическое этих чисел, b - на произведение этих чисел и распечатываем их} begin a:= (a + b) / 2; b:= c * b; writeln('a < b => a = ', a, ', b = ', b); end; if b < a then {Если b < a, то заменяем а на произведение чисел, b - на среднее арифметическое чисел} begin a:= a * b; b:= (c + b) / 2; writeln('b < a => a = ', a, ', b = ', b); end; if a = b then writeln('Числа равны'); {Числа числа равны, то печатаем сообщение об этом} end. Если все правильно, отметь решение как лучшее)
Не нашли ответ?
Похожие вопросы