Составьте программу на Паскале.Даны три различных вещественных числа,найти среднее из них.Среднее число- это такое , которое больше наименьшего из данных чисел,но меньше наибо

Составьте программу на Паскале.Даны три различных вещественных числа,найти среднее из них.Среднее число- это такое , которое больше наименьшего из данных чисел,но меньше наибо льшего.
Гость
Ответ(ы) на вопрос:
Гость
//Pascal ABC.NET 3.1 сборка 1219 Var a,b,c:real; begin read(a,b,c); if ((a>b) and (a<c)) or ((a<b) and (a>c)) then writeln(a); if ((b>a) and (b<c)) or ((b<a) and (b>c)) then writeln(b); if ((c>a) and (c<b)) or ((c<a) and (c>b)) then writeln(c); end. Пример ввода: 1.1 1.2 1.3 Пример вывода: 1.2
Не нашли ответ?
Ответить на вопрос
Похожие вопросы