Срочно нужно решить 3 задачи на формирование массива Количество элементов произвольное. 1. Составить программу , которая формирует массив (автоматически) из целых значений в интервале [0,20], выводит и подсчитывает среднее знач...

Срочно нужно решить 3 задачи на формирование массива Количество элементов произвольное. 1. Составить программу , которая формирует массив (автоматически) из целых значений в интервале [0,20], выводит и подсчитывает среднее значение всех элементов массива. 2.Составить программу , которая формирует автоматически массив из целых значений в диапазоне [10,30) и подсчитывает количество элементов значение которых больше 15. 3. Составить программу , которая формирует массив из целых чисел и подсчитывает количество отрицательных элементов. Организовать ввод элементов с клавиатуры. УБЕДИТЕЛЬНАЯ ПРОСЬБА КТО ЗНАЕТ НОРМ САЙТ С ОБЪЯСНЕНИЕМ МАССИВА ИЛИ ВИДЕО СКИНЬТЕ ССЫЛКУ . ЗАРАНЕЕ СПАСИБО ЗА ПОМОЩЬ!!!
Гость
Ответ(ы) на вопрос:
Гость
1)  const     k = 15;    var       a : array [1..k] of integer;       s : real;        i : integer;  begin   randomize;   s := 0;  for i := 1 to k do       //Обработка массива чаще всего    begin                      //осуществляется в цикле     a[i] := random(21);         //Формирование     s := s + a[i];                      //Подсчет суммы элементов end;   s := s / k;                              //Среднее арифметическое (сумма/кол - во) writeln (s:3:3);  end. 3)  const     n = 5;         var             a : array [1..n] of integer;              i,k : integer;   begin  k := 0;      for i := 1 to n do             begin        readln (a[i]);             //Считываем элемент    if a[i] < 0 then          //Если элемент меньше нуля      k := k +1;                  //счетчик +1            end;    writeln (k);   end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы