Срочно!!!! Помогите пожалуйста!!! Программы паскалясоставьте программу решения квадратного уравнения ax2 +bx +c=0 Коэффициенты a в с введите с клавиатуры. Выведите на экран значения корней x1 x2 если уравнение имеет два корня, ...
Срочно!!!! Помогите пожалуйста!!! Программы паскаля
составьте программу решения квадратного уравнения ax2 +bx +c=0 Коэффициенты a в с введите с клавиатуры. Выведите на экран значения корней x1 x2 если уравнение имеет два корня, значение x, если уравнение имеет один корень, или сообщение "Нет корней", если уравнение не имеет корней.
Ответ(ы) на вопрос:
var
a, b, c, d, x1, x2: real;
begin
Write('Введите через пробел значения a,b,c: ');
Readln(a, b, c);
d := sqr(b) - 4 * a * c;
if d < 0 then Writeln('Нет действительных корней')
else if d = 0 then Writeln('Один корень ', -b / (2 * a))
else
begin
d := sqrt(d);
x1 := (-b - d) / (2 * a);
x2 := (-b + d) / (2 * a);
Writeln('x1=', x1, ', x2=', x2)
end
end.
Тестовое решение:
Введите через пробел значения a,b,c: 4 3.2 -2
x1=-1.2124038404636, x2=0.412403840463596
[latex]ax^2+bx+c=0 \\ D=b^2-4ac \\ x= \frac{-b\mp \sqrt{D}}{2a} [/latex]
Не нашли ответ?
Похожие вопросы