!!Срочно!! (рисунок номер11)Написать программу, которая определяет, попадает ли точка с заданными координатами в область, закрашенную область. Программа нужна на паскале!Помогите пожалуйста!
!!Срочно!! (рисунок номер11)Написать программу, которая определяет, попадает ли точка с заданными координатами в область, закрашенную область. Программа нужна на паскале!Помогите пожалуйста!
Ответ(ы) на вопрос:
Гость
var
R,x,y: real;
t: boolean;
begin
read(R,x,y);
t := (x <= 0) and (y <= 0) and (x + y >= -R);
t := t or (x >= 0) and (y >= 0) and (sqr(x) + sqr(y) <= sqr(R));
writeln(t)
end.
Не нашли ответ?
Похожие вопросы