СРОЧНО!!!МНОГО БАЛЛОВ1. Написать программу, которая заполняет массив с клавиатуры целыми числами и распечатывает его элементы в обратном порядке. Массив описывается через константу N. Для проверки взять N=5. То есть выводится A...
СРОЧНО!!!МНОГО БАЛЛОВ
1. Написать программу, которая заполняет массив с клавиатуры целыми числами и распечатывает его элементы в обратном порядке. Массив описывается через константу N. Для проверки взять N=5. То есть выводится A[5], A[4],…,A[1].
Пример выполнения программы:
Входные данные Выходные данные
2 3 6 4 8 --> 8 4 6 3 2
2. Написать программу, которая выводит на печать каждый третий элемент массива (или те элементы, индекс которых кратен 3). Массив описывается через константу N. Для проверки взять N=10.
Пример выполнения программы:
Входные данные Выходные данные
1 2 3 4 5 6 7 8 9 10--> 3 6 9
Ответ(ы) на вопрос:
1.
const n=5;
var
a: array[1..n] of integer;
i: integer;
begin
for i:=1 to n do
read(a[i]);
for i:=n downto 1 do
write(a[i], ' ');
end.
2.
const n=10;
var
a: array[1..n] of integer;
i: integer;
begin
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if i mod 3 = 0 then
write(a[i], ' ');
end.
Не нашли ответ?
Похожие вопросы