Срооочно!!!нужно составить программу на Паскалена квадратное уравнение!

Срооочно!!! нужно составить программу на Паскале на квадратное уравнение!
Гость
Ответ(ы) на вопрос:
Гость
var a,b,c:integer; x1,x2,d:real; begin writeln ('Введите коэффициенты уравнения:'); readln (a,b,c); if a=0 then writeln('уравнение не квадратное') else begin  d:=b*b-4*a*c;  if d<0 then writeln ('уравнение не имеет действительных корней') else if d=0 then begin x1:=-b/(2*a); writeln('x1=x2=',x1:0:2);    end else if d>0 then begin x1:=(-b-sqrt(d))/(2*a); x2:=(-b+sqrt(d))/(2*a); writeln('x1=',x1:0:2,'  x2=',x2:0:2); end; end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы