Требовалось написать программу которая решает уравнение а|x|=b относительно х для любых чисел а и b, введенных с клавиатуры
Требовалось написать программу которая решает уравнение а|x|=b относительно х для любых чисел а и b, введенных с клавиатуры
Ответ(ы) на вопрос:
var a,b:integer; x:real;
begin
readln (a,b);
x:=abs(b/a);
writeln (x:0:2);
end.
АБС это модуль, но я могу и ошибаться, тогда
var a,b:integer; x:real;
begin
readln (a,b);
If a<0 then a:=a*(-1);
If b<0 then b:=b*(-1);
x:=abs(b/a);
writeln (x:0:2);
end.
Не нашли ответ?
Похожие вопросы