Требуется найти сумму цифр числа( 5.....5)²,где 0 меньше n меньше 19000. Составьте программу.

Требуется найти сумму цифр числа( 5.....5)²,где 0< n<19000. Составьте программу.
Гость
Ответ(ы) на вопрос:
Гость
Стал ещё сильнее уважать свой ноут:) uses   System.Numerics; var   k, m: BigInteger;   n, j: word; begin   readln(n);   for j := 1 to n do     k := k * 10 + 5;   k := k * k;   writeln(n, ' ', k);   repeat     m := m + (k mod 10);     k := k div 10;   until (BigInteger.Parse(k.toString()).isZero); //нет, isZero просто так не принимает IDE   k := 0;   writeln('Sum: ', m); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы