УмоляюююююююююююююююПЛИИИИЗТОЛЬКО НА ПАСКАЛЕЕЕЕЕ Напишите функцию bool Xor (bool x, bool y) (C/C++), function _Xor (x, y:boolean): boolean (Pascal), def xor(x, y):(Python) реализующую функцию "Исключающее ИЛИ" двух логическ...
Умоляююююююююююююююю
ПЛИИИИЗ
ТОЛЬКО НА ПАСКАЛЕЕЕЕЕ
Напишите функцию
bool Xor (bool x, bool y) (C/C++),
function _Xor (x, y:boolean): boolean (Pascal),
def xor(x, y):(Python)
реализующую функцию "Исключающее ИЛИ" двух логических переменных x и y. Функция Xor должна возвращать true, если ровно один из ее аргументов x или y, но не оба одновременно равны true.
Входные данные
Вводится 2 числа - x и y (x и y равны 0 или 1, 0 соответствует значению false, 1 соответствует значению true).
Выходные данные
Необходимо вывести 0 или 1 - значение функции от x и y.
Ответ(ы) на вопрос:
Гость
function _Xor (x,y:boolean):boolean;
begin
_Xor:=x<>y;
end;
var x,y:byte;
begin
write('x = ');
readln(x);
write('y = ');
readln(y);
writeln(ord(_Xor(x=1,y=1)));
end.
Пример:
x = 1
y = 0
1
Не нашли ответ?
Похожие вопросы