Уровень A. Напишите программу, в которой сортировка выполняется «методом камня» – самый «тяжёлый» элемент опускается в конец массива.

Уровень A. Напишите программу, в которой сортировка выполняется «методом камня» – самый «тяжёлый» элемент опускается в конец массива.
Гость
Ответ(ы) на вопрос:
Гость
var a:array[1..10000] of integer; n,i,j,k,t:integer; begin readln(n); for i:=1 to n do read(a[i]); j:=n; repeat k:=j; j:=0; for i:=1 to k-1 do if a[i+1]j:=i; t:=a[i]; a[i]:=a[i+1]; a[i+1]:=t; for t:=1 to n do write(a[t],' '); writeln; end; until j=0; if k=n then writeln(0); //Если перестановок не было, программа выводит только число 0. Если эта команда не нужна, можешь ее убрать end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы