Уровень C. Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи. Уровень D (на дополнительную оценку, не обязательная). Напишите программу, которая получает с кл...

Уровень C. Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи. Уровень D (на дополнительную оценку, не обязательная). Напишите программу, которая получает с клавиатуры натуральное число и определяет, есть ли в его десятичной записи одинаковые цифры, стоящие рядом.
Гость
Ответ(ы) на вопрос:
Гость
Уровень C #include using namespace std; int main() {     int n;     cin >> n;     int maxdigit = 0;     while (n > 0) {         int digit = n % 10;         if (digit > maxdigit)             maxdigit = digit;         n /= 10;     }     cout << maxdigit;     return 0; } Уровень D #include using namespace std; int main(){     int n;     cin >> n;     int prev = -1;     while (n > 0) {         int digit = n % 10;         if (digit == prev) {             cout << "YES";             return 0;         }         prev = digit;         n /= 10;     }     cout << "NO";     return 0; }
Не нашли ответ?
Ответить на вопрос
Похожие вопросы