В массиве хранится информация о среднесуточной температуре за текущую неделю. Составить программу, определяющую среднюю температуру за неделю и количество дней, в течение которых температура была выше средней

В массиве хранится информация о среднесуточной температуре за текущую неделю. Составить программу, определяющую среднюю температуру за неделю и количество дней, в течение которых температура была выше средней
Гость
Ответ(ы) на вопрос:
Гость
var a: array[1..7] of integer; i, k: integer; s: real; begin for i:=1 to 7 do begin write('Введите погоду для ', i, ' дня недели: '); readln(a[i]); s:=s+a[i] end; s := s/7; k:=0; for i:=1 to 7 do if a[i] > s then inc(k); writeln('Средняя температура: ', s); writeln('Кол-во дней: ', k); end.
Гость
//Pascal ABC.NET v3.0 сборка 1111 Const  n=7; Var  ar:array[1..n] of integer; //массив дней  i,k:integer;  sr:real; begin k:=0; //счётчик превысивших  for i:=1 to n do    begin    readln(ar[i]); //вводим дни    sr:=sr+ar[i]; //заодно вычисляем сумму дневных температур   end;  sr:=sr/n; {делим сумму на количество дней, получаем среднюю температуру}  for i:=1 to n do    if sr
Не нашли ответ?
Ответить на вопрос
Похожие вопросы