(в паскале помогите написать программу) Оставьте в строке только первые вхождения букв, все повторяющиеся буквы удалите. Например, исходное слово «кроссворд» (или «missisipi»), результат «кросвд» (или «misp»).

(в паскале помогите написать программу) Оставьте в строке только первые вхождения букв, все повторяющиеся буквы удалите. Например, исходное слово «кроссворд» (или «missisipi»), результат «кросвд» (или «misp»).
Гость
Ответ(ы) на вопрос:
Гость
var   i,x:integer;   s:string; begin readln(s); for i:=length(s) downto 1 do   begin   x:=pos(s[i],s);   if x<>i then delete(s,i,1);   end; writeln(s) end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы