Всем привет. Вообщем, вот задача и к ней необходимо написать программу(Pascal). Код программы будет ниже.Нужно проверить его на ошибки и дать коментарии к коду. Если код неправильный прошу подкорректировать. Буду очень признате...
Всем привет.
Вообщем, вот задача и к ней необходимо написать программу(Pascal). Код программы будет ниже.Нужно проверить его на ошибки и дать коментарии к коду. Если код неправильный прошу подкорректировать. Буду очень признателен. Заранее спасибо.
Задача:
Дана последовательность из n действительных чисел (n <= 100). Написать программу для подсчета суммы этих чисел.
Код программы:
var massiv: array [1..100] of real;
sum: real;
n,i: integer;
begin
clrscr;
writeln ('Введите количество чисел');
readln (n);
for i:=1 to n do
begin
writeln ('Введите ',i,'-ое число');
readln (massiv [i]);
end;
sum:=0;
for i:=1 to n do
sum:= sum + massiv [i];
writeln ('Сумма последовательности равна ', sum:0:4);
readln;
end.
Ответ(ы) на вопрос:
var i,n:integer;
k,k1:real;
begin;
readln(n);
for i:=1 to n do //повторить n раз
begin; //начало тела цикла
readln(k1); //читаем промежуточную переменную
k:=k+k1; //прибавляем к общей сумме
end; //конец тела цикла
writeln('Result:',k); //вывод общей суммы
end.
Не нашли ответ?
Похожие вопросы