Вводится следующий поток данных: 7, 2, 3, -2, 4, -7, 10, 1 напишите программу по данной блок-схеме и вычислите результат ПОМОГИТЕ РЕШИТЬ. ПОЖАЛУЙСТА!!!!!!!!!

Вводится следующий поток данных: 7, 2, 3, -2, 4, -7, 10, 1 напишите программу по данной блок-схеме и вычислите результат ПОМОГИТЕ РЕШИТЬ. ПОЖАЛУЙСТА!!!!!!!!!
Гость
Ответ(ы) на вопрос:
Гость
var   n,s,k,a,i:integer; begin   Read(n);   s:=0; k:=0;   for i:=1 to n do begin     Read(a);     s:=s+a;     if a mod 2=0 then Inc(k)     end;   Writeln(s,' ',k) end.     Результат 7 2 3 -2 4 -7 10 1 11 4
Гость
var n,s,k,i:integer; a:array[1..10] of integer; begin readln(n); s:=0; k:=0; for i:=1 to n do begin read(a[i]); s:=s+a[i]; if a[i] mod 2 = 0 then k:=k+1; end; writeln(s,' ',k); end. Пример: 7 2 3 -2 4 -7 10 1 11 4
Не нашли ответ?
Ответить на вопрос
Похожие вопросы