Задача №1. Написать программу решения уравнения вида y=2x2+0,5z Uses Crt; Var y,x,z: real; BeginClrScr;Write(‘Введите значения переменных x,z’);Read(x,z); {ввод значений через пробел}y:= 2*x*x+0,5*z;Writeln(‘Результат вычисл...
Задача
№1.
Написать программу решения уравнения
вида y=2x2+0,5z
Uses Crt;
Var y,x,z: real;
Begin
ClrScr;
Write(‘Введите значения переменных x,z’);
Read(x,z); {ввод значений через пробел}
y:= 2*x*x+0,5*z;
Writeln(‘Результат вычислений y=’, y);
End.
Задание
№ 2. Написать программу для решения уравнения
(спомощью стандартных арифметических функции):
1.y=cos2x+sin3x
2.y=sin2π+π/2
3.y=tg x+0.25
4.y=|x|+2|z|
Ответ(ы) на вопрос:
Задание 2, 1:
program zadacha1;
uses crt;
var x, y: real;
begin
clrscr;
write('enter x: ');
readln (x);
x:=(x*pi)/180; // в Паскале используется измерение в радианах, здесь мы
// переводим из градусов (так как мы задаем значение в градусах) в радианы
y:=sqr(cos(x))+sqr(sin(x))*sin(x);
writeln ('y=', y:0:4);
readkey;
end.
2
program zadacha2;
uses crt;
var y: real;
begin
clrscr;
y:=sqr(sin(pi))+ pi/2;
writeln ('y=', y:0:4);
readkey;
end.
3
program zadacha3;
uses crt;
var x, y: real;
begin
clrscr;
write ('enter x: ');
readln (x);
x:=(x*pi)/180;
y:=sin(x)/cos(x) + 0.25;
writeln ('y=', y:0:4);
readkey;
end.
4
program zadacha4;
uses crt;
var x, y, z: integer;
begin
clrscr;
write ('enter x, z');
readln (x, z);
y:=abs(x)+2*abs(z);
writeln ('y=', y:0:4);
readkey;
end.
Не нашли ответ?
Похожие вопросы