Задача 1. Напишите программу на языке pascal: Ввести число, если это число отрицательное (например: -5), то программа должна вывести "число -5 отрицательное ", если число положительное (например:452) то программа должна вывести...

Задача 1. Напишите программу на языке pascal: Ввести число, если это число отрицательное (например: -5), то программа должна вывести "число -5 отрицательное ", если число положительное (например:452) то программа должна вывести "число 452 положительное". На оценку 4 еще рассмотреть случай когда вводится число 0 На оценку 5 еще рассмотреть случай, когда используются метки для многократного введения чисел.
Гость
Ответ(ы) на вопрос:
Гость
//Pascal ABC.Net Var a:array[1..1000] of longint;n,i:longint; Begin writeln('Введите количество чисел'); readln(n); writeln('Введите числа'); for i:=1 to n do read(a[i]); for i:=1 to n do if (a[i]<0) then writeln('Число ',a[i],' отрицательное') else if (a[i]>0) then writeln('Число ',a[i],' положительное') else writeln('Число ',a[i],' равно нулю'); End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы