Задача 1.Составьте программу, которая выводит на экран таблицу перевода a, a+1, a+2, … b бит в килобайты. Границы a и b вводятся с клавиатуры. Протокол:Введите границы: 5000 5004 5000 бит = 0.61035 Кб 5001 бит = 0.61047 Кб...
Задача 1.
Составьте программу, которая выводит на экран таблицу
перевода a, a+1,
a+2, … b бит в килобайты. Границы
a и b вводятся с клавиатуры.
Протокол:
Введите границы: 5000 5004
5000 бит = 0.61035 Кб
5001 бит = 0.61047 Кб
5002 бит = 0.61060 Кб
5003 бит = 0.61072 Кб
5004 бит = 0.61084 Кб
Задача 2.
Составить программу для нахождения суммы по следующей формуле: где
m вводится с клавиатуры.
Задача 3.
Составить программу для решения следующей задачи: Ежемесячная стипендия студента
составляет A рублей в месяц, а расходы на проживание превышают стипендию
и составляют B рублей в месяц. Рост цен ежемесячно увеличивает расходы на
3%. Разработать схему алгоритма для расчёта необходимой суммы денег, которую
надо единовременно попросить у родителей, чтобы можно было прожить учебный год
(10 месяцев), используя только эти деньги и стипендию.
Ответ(ы) на вопрос:
1)
var
a, b, i: longint;
begin
read(a, b);
for i := a to b do
writeln(i:10, ' бит = ', i / 8 / 1024:10:5, ' Кб');
end.
3)
var
a, b, s: real;
i:integer;
begin
read(a, b);
for i := 1 to 10 do
begin
s := s + b;
b := b * 1.03;
end;
writeln(s - 10 * a);
end.
Не нашли ответ?
Похожие вопросы