Задача 2. Напишите программу,которая в последовательности натуральных чисел определяет минимальное чётное число. Программа получает на вход количество чисел в последовательности ,а затем сами числа.В последовательности всегда и...
Задача 2. Напишите программу,которая в последовательности натуральных чисел определяет минимальное чётное число.
Программа получает на вход количество чисел в последовательности ,а затем сами числа.В последовательности всегда имеется четное число.Количество чисел не превышает 1000.Введенные числа не превышают 30 000.Программа должна вывести одно число-минимальное чётное число.
Ответ(ы) на вопрос:
Гость
var
i, min, n, d: integer;
begin
readln(n);
min:=30000;
for i := 1 to n do
begin
readln(d);
if (d mod 2 = 0) and (min>d) then
min:=d
end;
writeln(min);
end.
Не нашли ответ?
Похожие вопросы