Задача 2. Составьте программу для нахождения количества литров L, которое содержится в X галлонах (1 галлон = 4,54609 литра). Исходное количество галлонов задается с клавиатуры. Задача 3. Напишите программу вычисления общего чл...
Задача 2. Составьте программу для нахождения количества литров L, которое содержится в X галлонах (1 галлон = 4,54609 литра). Исходное количество галлонов задается с клавиатуры.
Задача 3. Напишите программу вычисления общего члена Bn и суммы Sn первых n членов геометрической прогрессии. Первый член прогрессии b1, знаменатель прогрессии q и число членов задаются с клавиатуры.
Ответ(ы) на вопрос:
//PascalABC.NET 3.2 сборка 1318
Const
gal=4,54609;
Var
x:real;
begin
readln(x);
writeln(x*gal);
end.
//2
Var
b1,q:real;
n:integer;
begin
readln(b1,q,n);
if (b1=0) or (q=0) then
begin
writeln('b1=0 or q=0');
exit;
end
else
if q=1 then
begin
writeln('Sum=',b1*n);
writeln('Bn=',b1);
end
else
begin
Writeln('Sum=',b1*(1-power(q,n))/(1-q));
Writeln('Bn=',b1*power(q,n-1));
end;
end.
Не нашли ответ?
Похожие вопросы