Задача на циклы,пожалуйста,напишите программу Составьте программу определения наибольшего общего делителя двух натуральных чисел. (3 балла)

Задача на циклы,пожалуйста,напишите программу Составьте программу определения наибольшего общего делителя двух натуральных чисел. (3 балла)
Гость
Ответ(ы) на вопрос:
Гость
Используем стандартный алгоритм нахождения Нод. Program n1; Uses CRT; Var a,b,c: integer; begin ClrScr; Writeln('Vvedite A i B'); Readln(a,b); while b<>0 do begin c := a mod b; a := b; b := c; end; writeln('NOD =',a); readln end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы