Задание 3. Только чётные! Напишите программу, которая заполняет массив из N элементов целыми четными числами. Гарантируется, что 0  меньше N ≤ 10000 . Формат ввода Входная строка содержит 2 числа N - количество элементов, А - ...

Задание 3. Только чётные! Напишите программу, которая заполняет массив из N элементов целыми четными числами. Гарантируется, что 0 < N ≤ 10000 . Формат ввода Входная строка содержит 2 числа N - количество элементов, А - начальное значение Формат вывода Программа должна вывести N элементов построенного массива, начиная с A, если А - четное и с А + 1, если А - нечетное, разделенных пробелами Пример 1 Ввод 5 4 Вывод 4 6 8 10 12 Пример 2 Ввод 5 5 6 8 10 12 14 пожалуйста
Гость
Ответ(ы) на вопрос:
Гость
Var A,N:integer; M:array[1..10001] of integer; Begin ReadLn(N,A); if A mod 2<>0 then A:=A+1; For N:= 1 to N do     Begin     M[N]:=A;     A:=A+2;     Write(M[N],' ')     End; End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы