Задано существительное 1-го склонения, оканчивающееся на «а». Составьте программу, позволяющую вывести на экран это слово во всех падежах.
Задано существительное 1-го склонения, оканчивающееся на «а». Составьте программу, позволяющую вывести на экран это слово во всех падежах.
Ответ(ы) на вопрос:
var a: string;
begin
write ('Введите слово: '); read (a);
writeln ('Именительный падеж: ',copy(a,1,length(a)));
writeln ('Родительный падеж: ',copy(a,1,length(a)-1),'ы');
writeln ('Дательный падеж: ',copy(a,1,length(a)-1),'е');
writeln ('Винительный падеж: ',copy(a,1,length(a)-1),'у');
writeln ('Творительный падеж: ',copy(a,1,length(a)-1),'ой');
writeln ('Предложный падеж: ',copy(a,1,length(a)-1),'е');
end.
Основной момент, это удаление окончания путем копирования слова в строке a начиная с первого символа, до длины слова минус 1 символ.
Не нашли ответ?
Похожие вопросы