Заданы длины катетов прямоугольного треугольника. составьте программу,с помощью которой определите радиус вписанной и радиус описанной окружности.

Заданы длины катетов прямоугольного треугольника. составьте программу,с помощью которой определите радиус вписанной и радиус описанной окружности.
Гость
Ответ(ы) на вопрос:
Гость
Формулы: с=кв.корень из (а^2+b^2) r=(a+b-c)/2 R=c/2 var   a,b,c,r1,r2: real; begin   write ('введите катет а: ');   readln (a);   write ('введите катет b: ');   readln (b);   c:=sqrt(a*a+b*b);   r1:=(a+b-c)/2; //радиус вписанной окружности   r2:=c/2; //радиус описанной окружности   writeln;   writeln ('r = ',r1:6:2);   writeln ('R = ',r2:6:2); end. ------------------------------------------------------------------- Пример: введите катет а: 4 введите катет b: 6 r =   1.39 R =   3.61 ***значения округлены до 2 знаков после запятой
Не нашли ответ?
Ответить на вопрос
Похожие вопросы