1) С клавиатуры вводят слово и символ. Составьте программу, которая:                              а) определяет позицию заданного символа                                                                          б) подсчитывает ...

1) С клавиатуры вводят слово и символ. Составьте программу, которая:                              а) определяет позицию заданного символа                                                                          б) подсчитывает количество вхождений заданного символа.
Гость
Ответ(ы) на вопрос:
Гость
Program Zadacha; Var s: String; c: Char; i, pos, count: Integer; Begin WriteLn('Введите слово:'); ReadLn(s); WriteLn('Введите символ:'); ReadLn(c); pos := 0; count := 0; For i := 1 To Length(s) Do If s[i] = c Then Begin count := count + 1; If pos = 0 Then pos := i; End; WriteLn('Позиция символа в строке: ', pos); WriteLn('Количество вхождений символа в строку: ', count); ReadLn; End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы