1)Вычислить сумму цифр натурального числа Z, заданного пользователем. (Pascal ) 2)Создать приложение в Delphi, которое выводит двумерный массив случайных чисел в объекте StringGrid , ввести элементы с клавиатуры и посчитать сум...

1)Вычислить сумму цифр натурального числа Z, заданного пользователем. (Pascal ) 2)Создать приложение в Delphi, которое выводит двумерный массив случайных чисел в объекте StringGrid , ввести элементы с клавиатуры и посчитать сумму элементов. 3)Составить программу табулирования функции y = sin 2x + cos 3x на отрезке [-1,1] с шагом 0,2. ( Pascal ) 4)Записать в файл последовательного доступа N действительных чисел. Вычислить количество компонентов файла кратных трем и вывести на печать. ( Pascal ) 5)На языке Delphi создать проект «Поиск максимального элемента в числовом массиве», массив заполнить случайными числами и предусмотреть возможность просмотра элементов массива в текстовом поле. 6)Создать программу, выполняющую следующие действия. После запуска программы пользователь вводит свое имя, например, Александр. Появляется вопрос: "Александр, ты любишь читать?". Если пользователь нажмет на клавишу Да, то должна появиться реплика: "Молодец!", если он нажмет на клавишу Нет, то появится реплика: "Почему же? Надо читать". (Delphi)
Гость
Ответ(ы) на вопрос:
Гость
1) var a, z, s: integer; begin      write('Введите число: ');      read(z);      a := z;      while a > 0 do      begin            s := s + a mod 10;            a := a div 10      end;      write('Сумма цифр числа ', z, ' = ', s) end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы