Дан массив из 30 произвольных элементов, каждый из которых не больше 100. Найдите максимальный элемент кратный 9 (Программа паскаль)
Дан массив из 30 произвольных элементов, каждый из которых не больше 100. Найдите максимальный элемент кратный 9
(Программа паскаль)
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(30,1,100); a.Println;
var s:=a.Where(m->m mod 9=0);
if s.Count>0 then Writeln('Найдено значение ',s.Max)
else Writeln('Нет элементов, кратных 9')
end.
Пример
12 18 11 77 82 96 79 86 100 6 55 69 17 6 81 17 21 89 32 23 2 6 14 53 51 3 70 35 32 38
Найдено значение 81
Не нашли ответ?
Похожие вопросы