Дан массив из N целых чисел. Найти номер первого элемента, который равен количеству элементов, кратных 3.Составить программу АЛГОРИТМА ПОИСКА в Паскале
Дан массив из N целых чисел. Найти номер первого элемента, который равен количеству элементов, кратных 3.
Составить программу АЛГОРИТМА ПОИСКА в Паскале
Ответ(ы) на вопрос:
Гость
var
n,i,x:integer;
a:array[1..20]of integer;
begin
write('Массив: ');
for i:=1 to 20 do
begin
a[i]:=random(1,9);
write(a[i],' ');
if a[i] mod 3=0 then n:=n+1;
end;
writeln;
for i:=20 downto 1 do
if a[i]=n then x:=i;
writeln('Ответ: ',x)
end.
Не нашли ответ?
Похожие вопросы