Дан целочисленный одномерный массив. Составьте программу, которая искала бы наибольший положительный элемент.
Дан целочисленный одномерный массив. Составьте программу, которая искала бы наибольший положительный элемент.
Ответ(ы) на вопрос:
program primer;
const n=100;
var a:array[1..n] of integer;
i,max:integer;
begin
writeln('vvedite massiv');
for i:=1 to n do
readln(' ', a[i]);
max:=a[1];
for i :=1 to n do
if (a[i]>a[1]) and (a[i]>0) then max:=a[i];
writeln('max=',max);
readln;
end.
Не нашли ответ?
Похожие вопросы