Дана последовательность натуральных 3-х значных чисел, за которой следует 0. Составить программу поиска в данной последовательности элемента, сумма цифр которого равна N Делать программу через цикл While
Дана последовательность натуральных 3-х значных чисел, за которой следует 0. Составить программу поиска в данной последовательности элемента, сумма цифр которого равна N
Делать программу через цикл While
Ответ(ы) на вопрос:
var
k: array[1..100] of integer;
a,N,i,c:integer;
begin
c:=0;
i:=1;
a:=999;
write('Введите N: ');
readln(N);
writeln('Введите a: ');
while a<>0 do beginr
eadln(a);
if (a>=100) and (a<=999) then begin
if ((a div 100)+((a div 10) mod 10)+(a mod 10))=N then begin
k[i]:=a;
i:=i+1;
c:=c+1;
end;
end;
end;
if c>0 then begin
writeln('Числа, сумма цифр которых равна ',N,':');
for i:= 1 to c do
writeln(k[i]);
end;
end.
Не нашли ответ?
Похожие вопросы