Дано натуральное число n (n меньше 10в6n меньше 106). Заполнить массив его цифрами, расположенными в обратном порядке, т.е. первый элемент равен последней цифре, второй — предпоследней и т.д. Незаполненные элементы массива долж...

Дано натуральное число n (n<10в6n<106). Заполнить массив его цифрами, расположенными в обратном порядке, т.е. первый элемент равен последней цифре, второй — предпоследней и т.д. Незаполненные элементы массива должны быть равны нулю. Элементы массива, являющиеся цифрами числа n вывести на экран. Формат входных данных С клавиатуры вводится натуральное число n (n<10в6n<106). Формат выходных данных Требуется вывести содержимое массива после заполнения согласно условию задачи. Элементы должны разделяться пробелами. Примеры:  входные данные:12  выходные данные:2 1
Гость
Ответ(ы) на вопрос:
Гость
var a:array[1..10] of integer; n,k,i:integer; begin write('n = '); readln(n); k:=0; while n>0 do  begin  k:=k+1;  a[k]:=n mod 10;  n:=n div 10;  end; for i:=1 to 10 do write(a[i],' '); end. Пример: n = 456387 7 8 3 6 5 4 0 0 0 0 
Не нашли ответ?
Ответить на вопрос
Похожие вопросы