Дано натуральное число N,последовательность целых чисел A1,A2,...An.Составить программу ,которая последовательно прибавляя членв последовательности, выводит результат,когда сумма впервые превышает число N. Если сумма всех члено...
Дано натуральное число N,последовательность целых чисел A1,A2,...An.Составить программу ,которая последовательно прибавляя членв последовательности, выводит результат,когда сумма впервые превышает число N. Если сумма всех членов последовательности не превышает число N, выведите об этом сообщение
Ответ(ы) на вопрос:
const
n = 5;
var
arr: array [1..n] of integer;
i, N1, sum: integer;
begin
write('N = ');
readln(N1);
for i := 1 to n do
begin
write('A[', i, '] = ');
readln(arr[i]);
end;
i := 1;
sum := 0;
while (sum <= N1) and (i <= n) do
begin
sum := sum + arr[i];
i := i + 1;
end;
if sum > N1 then
writeln(sum)
else
writeln('Summa not grether then N');
end.
Не нашли ответ?
Похожие вопросы