Даны две дроби a/b и c/d (a,b,c,d - натуральные числа). составить программу деления дроби на дробь. ответ должен быть несократимой дробью. использовать подпрограмму алгоритма Евклида для определения НОД

Даны две дроби a/b и c/d (a,b,c,d - натуральные числа). составить программу деления дроби на дробь. ответ должен быть несократимой дробью. использовать подпрограмму алгоритма Евклида для определения НОД
Гость
Ответ(ы) на вопрос:
Гость
Var  a, b, c, d, Num, Denom, Divis: Integer;   Function gcd(a, b: Integer): Integer; Var Temp: Integer; Begin   While b > 0 Do   Begin     Temp := b;     b := a mod b;     a := Temp   End;   gcd := a; End; Begin   WriteLn('Введите числа A, B, C, D: ');   Read(a, b, c, d);   Num := a * d;   Denom := b * c;   Divis := gcd(Num, Denom);   WriteLn(Num div Divis, '/', Denom div Divis); End.
Гость
function NOD(x,y:integer):integer; begin while (x<>0)and(y<>0) do  if x>y then x:=x mod y else y:=y mod x; NOD:=x+y; end; var a,b,c,d,n,z1,z2:integer; begin writeln('1-я дробь (числитель и знаменатель):'); readln(a,b); writeln('2-я дробь (числитель и знаменатель):'); readln(c,d); n:=nod(a*d,b*c); z1:=a*d div n;  z2:=b*c div n; writeln(z1,'/',z2); end. Пример: 1-я дробь (числитель и знаменатель): 5 6 2-я дробь (числитель и знаменатель): 2 8 10/3
Не нашли ответ?
Ответить на вопрос
Похожие вопросы