Используя метод нисходящего проектирования, разработать схему алгоритма и составить программу вычисления функции при заданных значениях аргументов. Результаты вычислений напечатать.

Используя метод нисходящего проектирования, разработать схему алгоритма и составить программу вычисления функции при заданных значениях аргументов. Результаты вычислений напечатать.
Гость
Ответ(ы) на вопрос:
Гость
Проектировать здесь нечего, так как задача - простейшая. Блок-схема - в прилагаемом файле. Программа: var x,p:integer; f:real; begin writeln('x    F'); p:=1; writeln(x,' ',exp(0)-p:5:2); for x:=1 to 6 do  begin  p:=p*x;  f:=exp(-x)-p;  writeln(x,' ',f:8:4);  end; end. Результат: x    F 0  0.00 1  -0.6321 2  -1.8647 3  -5.9502 4 -23.9817 5 -119.9933 6 -719.9975
Не нашли ответ?
Ответить на вопрос
Похожие вопросы