Используя, оператор цикла Repeat . . . until написать программу

Используя, оператор цикла Repeat . . . until написать программу
Гость
Ответ(ы) на вопрос:
Гость
const e=0.001; var x,a,s:real; n,st,f:integer; begin write('x = '); readln(x); st:=1; f:=1; a:=x; s:=x; n:=0; while abs(a)>e do  begin  n:=n+1;  st:=st*2;  f:=f*n;  a:=x*st/f;  s:=s+a;  end; writeln('s = ',s:5:3); end. Пример: x = 1.5 s = 11.083
Не нашли ответ?
Ответить на вопрос
Похожие вопросы