КТО МОЖЕТ ЗАПИСАТЬ НА ПАСКАЛЕ!!!!!!!! Дана квадратная матрица размера N. Заполнение матрицы осуществляется с клавиатуры. Составьте программу, определяющую истинность высказывания. Если высказывание истинно, то вывести «true», и...
КТО МОЖЕТ ЗАПИСАТЬ НА ПАСКАЛЕ!!!!!!!!
Дана квадратная матрица размера N. Заполнение матрицы осуществляется с клавиатуры. Составьте программу, определяющую истинность высказывания. Если высказывание истинно, то вывести «true», иначе вывести «false».
«В данной матрице произведение элементов, стоящих над побочной диагональю, равно произведению элементов, стоящих над главной диагональю».
Ответ(ы) на вопрос:
Гость
const nx=20;var i,j,n:integer; D:array[1..nx,1..nx] of integer;pG,pP:double;m:boolean;begin
write('Введите размер массива n');Readln(n);pG:=1;pP:=1;
for i:=1 to n do begin
for j:=1 to n do begin
Readln(D[i,j]);//D[i,j]:= random(35)-15;end;end;writeln;
for i:=1 to n do beginfor j:=1 to n do begin
write(D[i,j]:4);end;writeln;end;writeln;
for i:=1 to n do begin
for j:=1 to n do begin
if i < n-j+1 then begin write(D[i,j]:4); pP:= pP * D[i,j];end else write(' ':4);end;writeln;end;writeln;
for i:=1 to n do begin
for j:=1 to n do begin
if i
Гость
Var
a: Array[1..100,1..100] of Integer;
n,p1,p2, i,j: Integer;
r:boolean;
BEGIN
writeln('n=');
readln(n);
Writeln('vvedite massiv:');
For i:=1 to n do
begin
For j:=1 to n do
begin
read(a[i,j]);
end;
Writeln;
end;
r:=true;
p1:=1;
p2:=1;
for i:=1 to n do
for j:= 1 to n do
if i + j < n + 1 then
p1:=p1*a[i,j];
for i:=1 to n do
for j:= 1 to n do
if i
Не нашли ответ?
Похожие вопросы