На Паскале. В текстовый файл t1 записана последовательность целых чисел, разделенных пробелами. Написать программу, записывающую в текстовый файл t2 все положительные числа из t1.
На Паскале.
В текстовый файл t1 записана последовательность целых чисел, разделенных пробелами.
Написать программу, записывающую в текстовый файл t2 все положительные числа из t1.
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
var a:=ReadAllLines('int.txt').JoinIntoString.ToIntegers;
Print('Прочитано'); a.Println;
var b:=a.Where(x->x>0);
Print('Отобрано'); b.Println;
var f:=OpenWrite('out.txt');
foreach var e in b do Write(f,e,' ');
f.Close
end.
Тестовое решение:
Прочитано -5 8 -3 -2 0 -6 4 9 0 0 4 -4 -1 0 -1 3 6 7 1 8 0 2 -5 -2 9
Отобрано 8 4 9 4 3 6 7 1 8 2 9
Не нашли ответ?
Похожие вопросы