Написать программу, которая считывает число с экрана и выводит сумму цифр этого ч?

Написать программу, которая считывает число с экрана и выводит сумму цифр этого ч??сла. паскаль
Гость
Ответ(ы) на вопрос:
Гость
На Java http://pastebin.com/SbfSZLFK ввод - 1234567890123456 вывод - 66 var n, sum: integer; begin readln(n); sum := 0; while n > 0 do begin sum := sum + n mod 10; n := n div 10 end; writeln(sum); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы